Melde dich an, um diesem Inhalt zu folgen  
chsh

Problem mit Komfortsteuergerät

Recommended Posts

Hallo erstemal...

 

ich bin schon langer "stiller Leser" und wollte erstmal Danke sagen für die vielen Tipps, die ich hier lesen konnte!

 

Beim A2 meiner Frau (Bj. 2000, 1.4 Benziner) haben wir seit längerem ein Prob mit dem Komfortsteuergerät.

Ähnliche Symptome habe ich hier schon gelesen, aber ich werde nicht schlau daraus:

 

Wenn es kälter ist (auch schon so wie jetzt mit teilweise 8 -12° C morgens): Öffnen der Türen per Fernbedienung (manchmal muß man schon zweimal drücken, beim ersten Mal blinken nur die Blinker, beim zweiten Mal macht es Klack und alle Türen gehen auf)

Beim Starten des Motors macht es Klack und alle Türen sind zu (war früher nicht, ist wohl diese "während-der-Fahrt-an-der-Ampel-steh-nicht-einbrech-Sicherung"). Dann fährt man los und es macht im halb-Sekundentakt klack, klack, klack, als wenn einer ständig die Türöffnung drückt wird ständig die Türöffnung aktiviert, parallel dazu blinkt die Innenlleuchte (die wir natürlich auf "0" stellen, sonst wird man ja blöde!). Egal was man versucht (Türöffnung an Fahrertür auf oder zu, anhalten und Motor aus an, nix hilft). Das Ganze Spiel geht ungefär 10 Minuten, dann wird der Intervall langsamer, dann hört es schliesslich auf. (wohl, wenn es wärmer wird???)

Während dieser Klackerzeit kann man die Fenster nur ruckweise öffnen und schliessen.

 

Ich hatte das Komfortsteuergerät (hat hinten den Buchstabe "C", der ja böse sein soll....) ausgebaut, geöffnet, sieht aus wie NEU.

Habe jetzt auf ebay ein gebrauchtes mit Buchstabe "AE" von einem 2002er 1.4 Tdi erworben. Das habe ich eingebaut, damit funkionieren die Fensterheber, aber die Türöffnung und -schliessung geht nicht (weder über Funk, noch per Knopf Fahrertür, noch per Schliessung im Schloß)

 

Habe bei beiden Komfortsteuergeräten Batterie abgeklemmt, nix nützt was.

Ist nun das erworbene auch kaputt oder muß man die Dinger in der Werkstatt "neu initialisieren" oder so?

 

Was kann ich noch tun, wir wollen die Kugel bald verkaufen, weil wir keine zwei Autos mehr brauchen, aber so kann und will ich das natürlich niemandem verkaufen!

 

Ideen? - Würde mich riesig freuen.

 

Ich habe sogar einen Video gedreht, wie das wie wild klappert und der Werkstatt gezeigt - "Ähhh, keine Ahnung, müssen ma ma schauen" :kratz: - ich denke, da könnte ich hier im Forum kompetentere Antworten bekommen :D

 

Viele Grüße

Stefan

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Um sicher zu gehen, dass es wirklich am KSTG liegt, müsste man eigentlich das alte Steuergerät mal auslesen und gucken was da passiert oder ob vielleicht sogar ein eindeutiger Fehler drin steht. Es könnte ja auch sein, dass irgend ein Schalter, das Türschloss oder gar die Türsteuergeräte nen Schuss weg haben und dieses Problem auslösen. Das neue Steuergerät könnte auf dieses Problem evtl anders reagieren als das alte.

 

Fahr mal zur freien Werkstatt, lass dir das Komfortsteuergerät auslesen und gib mal Bescheid ob und was drin steht. Andernfalls müsste man sich mal die Messwertblöcke vom Steuergerät angucken, ob man hier vielleicht ablesen kann welcher Schalter aus Sicht des Steuergeräts immer auf und zu macht. Das würde dann aber etwas mehr Zeitaufwand bedeuten und dafür bräuchtest du ein Diagnosegerät.

 

Es ist leider so, dass nicht jedes Komfortsteuergerät in jedem A2 funktioniert. Ich hab leider noch nicht genug Komfortsteuergeräte queer getauscht, um da was über Wechselwirkungen sagen können. Ich weiß aber, dass es schon allein von der Frequenz der Funkfernbedinung Unterschiede gibt, die dazu führen, dass nicht jeder Schlüssel mit jedem Steuergerät funktionieren kann.

 

Dass das AE nicht in deinem Auto funktioniert kann also entweder an Inkompatibilität liegen, oder aber einfach daran, weil es kaputt ist.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
ich kann dein originales SG reparieren, wenn du Interesse hast...

 

Hallo Lau,

 

Ja, da habe ich Interesse, langsam habe ich Befürchtungen, dass die Türöffner vom ständigen Auf-Zu verrecken.

 

Schickst Du mir ne PM mit Deinen Kontaktdaten und den ungefären Kosten?

 

Danke auch A2-D2 für Deinen Tipp!

Gruß

Stefan

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo,

mein KSG hat den Geist aufgegeben.

Wo krieg ich ein gebrauchtes her das noch funktioniert?

Hab im Netz nicht viel gefunden.

 

Hinweis vom Moderator
Thema hier angefügt
bearbeitet von a2-701

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
ich kann dein originales SG reparieren, wenn du Interesse hast...

 

Hallo Forum,

 

mein KSG hat total gesponnen, alles was mit ZV, Fensterhebern etc. zu tun hatte, ging nicht mehr, bzw. hat wie wild herumgesponnen. Sogar die Gurte haben sich kaum noch aufgewickelt, keine Ahnung, ob das KSG dort über Gurtkraftbegrenzung mit spielt.

Habe das Teil zu "Lau" geschickt, er hat's repariert und nun geht wieder alles.

Jetzt macht A2-fahren wieder Spaß!!! :D

 

Viele Grüße

Stefan

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Kannst du was über Laufzeiten und Kosten erzählen?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Hallo Forum,

 

mein KSG hat total gesponnen, alles was mit ZV, Fensterhebern etc. zu tun hatte, ging nicht mehr, bzw. hat wie wild herumgesponnen. Sogar die Gurte haben sich kaum noch aufgewickelt, keine Ahnung, ob das KSG dort über Gurtkraftbegrenzung mit spielt.

Habe das Teil zu "Lau" geschickt, er hat's repariert und nun geht wieder alles.

Jetzt macht A2-fahren wieder Spaß!!! :D

 

Viele Grüße

Stefan

 

Der Gurtstraffer hat rein garnix mit dem KSTG zu tun :D

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Nein, er tauscht den Mikrocontroller aus und flasht den neu, die verbauten haben einen Serienfehler. Das kann er selbst aber vermutlich besser erklären.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Es handelt sich hierbei wahrscheinlich um das immer gleiche Problem mit dem MC68HC908AZ60 Mikrocontroller (oft sind Kombiinstrumente betroffen). Der Flash Speicher (dort wo das Programm liegt) kann nicht korrekt gelesen werden und so rödelt der µC ziellos vor sich hin. Dieser Vorgang ist einer teilweise defekten HDD in einem PC nicht unähnlich; bloß weniger komplex.

Ob der µC dann sporadisch noch funktioniert ist auch temperaturabhängig, der Niedergang des Speichers ist aber nicht aufzuhalten (Aufwärmen hilft, wie bei Batterien). Wahrscheinlich ist das Flashen in der Produktion nicht ordentlich ausgeführt worden (zu wenig Spannung) oder der auf dem µC enthaltene Flash ist nicht die allerbeste Konstruktion. 20 Jahre schaffen die Dinger idR ganz easy.

 

Möglich, dass der µC nur korrekt, neu beschrieben werden muss, dafür brauch man lediglich den Code der im Flash liegt/lag und Hardware zum programmieren der µC. Allerdings (ohne mich mit dem MC/Freescale Typ auszukennen) haben die µC in der Regel eine CodeProtection Funktion/Byte, das gesetzt ist um das Auslesen des Codes zu verhindern.

 

Aber für den A2 scheint es ja eine Lösung von Jemandem zu geben :), wobei ich eigentlich der Meinung bin, dass dieser Fehler dem Hersteller anzukreiden ist. Aber beweis sowas mal, wäre es das ESP oder besser noch Airbag STG hätte man wahrscheinlich schon Post vom KBA bzgl. Rückruf.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

... zu langsam...

 

Vereinzelt wird geschrieben, dass der µC Probleme mit dem ,stack pointer` hat und daher in Speicherbereiche springt in denen er nichts zu suchen hat und wo er keine sinnvollen Anweisungen mehr findet. Dann greift vmtl. irgendwann der Watchdog und resettet den µC.

Von den Controllern mit denen ich mich hauptsächlich beschäftige kenne ich solch ein Verhalten nicht, daher handelt es sich wohl um ein Design/Fertigungs-Fehler bestimmter Chargen des µC.

 

attachment.php?attachmentid=48791&stc=1&d=1393159950

KSG_CPU.jpeg.c42f10be71abd9d304f2cb56cfafdab0.jpeg

bearbeitet von Mankmil
...war zu langsam... :-)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Das der Stackpointer, also eigentlich die als Pointer genutzen Register niO sind kenne ich so auch nicht. Die werden beim booten initialisiert und zeigen dann eben auf die Zelle, die vom Code/Befehl angesagt wird. Was ich schon erlebt habe sind totgenudelte EEPROM Bytes, die dann eben auch im Programmabsturz und anschleißend Watchdog Reset enden.

 

Ich hatte den Hinweis auf fehlerhaft beschriebenen Flash in einem engl. TT-Forum aufgegriffen, wo eine Anfrage diesbezüglich direkt von Motorola beantwortet wurde. Siehe Quote:

 

Thank you for your interest in Freescale Semiconductors and for the

opportunity to serve you.

 

In reply to your Service Request:

 

We are not aware of reset problem at low temperature on MC68HC908AZ60.

 

Unexpected internal watchdog COP reset is probably due to code runaway.

This could be due to incorrect read of code or data in FLASH.

FLASH is the first feature to fail at low or high temperature.

Maybe these microcontrollers have been programmed out of the spec.

FLASH Data Retention Time is guaranteed for 10 years in the full temperature

range.

But, if the parts have been programmed out of specification, the data

retention time may be shorter and reduced to room temperature.

 

Could you erase the default parts and reprogram them. Probably they will

support cold temperature.

 

There is another issue to verify:

FLASH and EEPROM memory have limited erase and program endurance:

EEPROM Write/Erase Cycles @ 10 ms Write Time +125 °C: 10,000 Cycles

FLASH Row Program Endurance @ +125 °C: 100 cycles

Could you verify that the application doesn't erase and program FLASH or

EEPROM memory too many times.

 

NB:

MC68HC908AZ60 is an old product, replaced by MC68HC908AZ60A. These

microcontrollers are pin to pin compatible. However there are some

Differences Between the HC908AZ60A and the HC908AZ60. The following

application note AN2215/D should help the migration:

http://splashurl.com/ktkm6gr ... AN2215.pdf

 

It depends on the reason why the FLASH cell is not correctly read:

1) The cell is damaged.

2) The floating gate of the cell has not been charged correctly.

 

In case 1, erasing and reprogramming can't fix the problem

In case 2, erasing and reprogramming can fix the problem

 

I agree that it is safer to replace the microcontroller.

 

If this does not answer your question or if you need further assistance on

this service request, please do not hesitate to let us know.

 

http://www.ttforum.co.uk/forum/viewtopic.php?f=2&t=55361&hilit=motorola+dashpod&sid=89d7820ae62d095e8d37bc9de8914807&start=30

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
daher handelt es sich wohl um ein Design/Fertigungs-Fehler bestimmter Chargen des µC.

es handelt sich wohl darum dass Temic und Co (wohl auch Marelli, Siemens, Hella and weitere) die Mikrokontroller auf dem Band zu schnell beschreiben wollten, mit dem entsprechenden Ergebnis...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
es handelt sich wohl darum dass Temic und Co (wohl auch Marelli, Siemens, Hella and weitere) die Mikrokontroller auf dem Band zu schnell beschreiben wollten, mit dem entsprechenden Ergebnis...

 

Hi Lau,

 

hast Du es dann einfach (wie von Freescale empfohlen) mit Neu-Beschreiben probiert? Dann entfällt der Tausch des µC. Lediglich die 'codeprotection' muss geknackt werden - wenn vorhanden.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

es geht auch mit neu beschreiben, aber die uC sind nicht so teuer, Paar kaputte 2J74Y habe ich auch mal gehabt und ich möchte nicht dass jemand 3 Jahre später erzählt dass mein Eingriff nur befristet wirkt, weil z.B. bei der neuen Generation mit der ROM-Version (HC08, 1J35D) gehen öfter die Ausgänge kaputt so dass die Innenbeleuchtung nicht mehr funktioniert - ein bekanntes Problem und da kann ich leider nichts machen, da die Memory-Maps von 2J74Y und 1J35D unterschiedlich sind und die 1J35D können nicht so einfach durch die FLASH-Version ersetzt werden; ich habe versucht in IDA die Vector anzupassen aber ohne Erfolg...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Großen Respekt, dass Du die µC auslötest. :)

Ich habe da in Ermangelung eines Reflow-Ofens feinmotorisch so meine Probleme. :rolleyes:

 

Ist da seitens des Herstellers ein ,code-protection` drauf oder wußten sie gleich, dass man den knacken kann und haben's gelassen? :D

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

ich habe bis jetzt keine HC08 ohne Protection im Einsatz gesehen; Motorola fordert strengsten an das Kennwort zu setzen

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesem Inhalt zu folgen