Melde dich an, um diesem Inhalt zu folgen  
Ulrich

RNS-E Probleme?

Recommended Posts

Hallo A2-Gemeine,

 

habe da mal eine Frage zum RNS-E . Da mein altes RNS-E das Laufwerk defekt hatte und ich von einem Freund sein RNS-E aus einem Audi A3 (10 Jahre alt) günstig bekommen konnte, habe ich es kurzerhand ausgetauscht. Es lief auch nach der Lernphase des NAvi eigentlich gut.

Eine Sache die mir sofort auffiel, das Navi startete nicht mit Zündung an und ging nach dem Ausmachen und Schlüsselabziehen nicht aus.

Ok muß ich halt am Knopf drücken für aus und ein.  Jetzt hatte ich gestern das Phänomen, dass das RNS-E  (Radio war an) plötzlich während der Fahrt aus ging. Hatte dieses beim alten RNS-E nur wenn ohne Zündung das RAdio an war..und das schaltete sich so nach 1/2 Stunde dann von selbst aus.

 

Meine Fehlersuche würde ich jetzt in 2 Richtungen angehen?

1. Einstellungen für das RNS-E mit VAG-Com überprüfen ( z.B Codierung des Sound, Reifenumfang u.ä)  auch mit den Codeeinstellungen des alten RNS-E vergleichen?

2. Es gibt ja diese Sache , daß bei Audi für das RAdio Dauerplus und Schaltplus vertauscht sind.

Das Problem hatte ich auch nachdem ich aus meinem CAbrio Typ89 das normale Radio aus und ein Concert2 wieder eingebaut hatte.

Nur warum hat das alte RNS-E funktioniert. An dem Quadlockstecker oder anderswo ist nichts umgepinnt oder geändert worden..

 

Hat jemand noch eine Idee wie ich die Sache wieder wie vorher einstellen kann.

Alternativ würde ich sonst nach Sonsbeck zu Christian Hahnen fahren (CumCarTec) -einige kennen ihn..

 

Viele Grüße

Ulrich

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

War das RNS-E original, oder war ein RNS-D verbaut.

Das  RNS-D hat Zündungsplus und wird nicht über den

Can-Bus geschaltet.

 

MfG Chris

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor einer Stunde schrieb Ulrich:

1. Einstellungen für das RNS-E mit VAG-Com überprüfen ( z.B Codierung des Sound, Reifenumfang u.ä)  auch mit den Codeeinstellungen des alten RNS-E vergleichen?

Ja, fang damit an und hoffe, dass dein neues RNS-E der gleichen Generation ist und die codings übernimmt.

 

vor einer Stunde schrieb Ulrich:

2. Es gibt ja diese Sache , daß bei Audi für das RAdio Dauerplus und Schaltplus vertauscht sind.

Andere Baustelle, das RNS-E hat gar kein Zündplus, somit für dein Problem nicht relevant.

 

vor 14 Minuten schrieb 5-ender:

War das RNS-E original, oder war ein RNS-D verbaut.

RNS-E original gab es je gar nicht, somit wurde entweder schon was umgebuat oder es war tatsächlich ein RNS-D. In dem Fall müsste man jetzt was umbauen und CAN ans Radio anschliessen. Das beschriebene Verhalten spricht nämlich für fehlende CAN-Anbindung.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo..

 

zur Info..beides sind RNS-E und sind 2 Jahre vom Baujahr unterschiedlich und beide mit 192 am Ende.

 

ich gehe jetzt mal den Weg die Codierung zu überprüfen, die wird noch auf Audi a3 stehen.

.habe nur diese Liste der Codierung gefunden

    •  

Coding

  • 0?xxxxx: Model
    • 1 = Lamborghini
    • 2 = Audi A3 (8P)
    • 3 = Audi A4 (8E)
    • 4 = Audi A4 Cabriolet (8H)
    • 5 = Audi A6 (4B)
    • 6 = Audi TT (8J)
    • 7 = Audi R8 (42)
  • 0x?xxxx: Treble Speaker Diagnosis / Optical Parking Aid
    • +1 = Front Treble Speaker Diagnosis inactive
    • +2 = Optical Parking Aid installed/active
  • 0xx?xxx: Sound Characteristic
    • 0 = Sound Characteristic linear
    • 1 = Audi A4 (8E)
    • 2 = Audi A6 (4B)
    • 3 = Audi A4 Cabriolet (8H)
    • 4 = Audi TT (8J)
    • 5 = Audi A3 (8P)
    • 9 = Sound System
  • 0xxx?xx: Telephone Preparation
    • 1 = Telephone Preparation NOT installed
    • 2 = Telephone Preparation without Comfort Functionality
    • 3 = Telephone Preparation (Aftermarket Retrofit)
    • 4 = Base Plate (Nokia - Remote Feed Voltage for Microphone inactive)
    • 5 = Telematic Europa (Remote Feed Voltage for Microphone inactive)
    • 6 = Telephone Preparation for North American Region (NAR)
    • 7 = Telephone Preparation with Comfort Functionality
  • 0xxxx?x: Equipment I
    • +1 = Standard/Basic Value - Add to the Sum of Options below
    • +1 = Audi Music Interface (AMI/PR-UF7) installed
    • +2 = Satellite Radio (SIRIUS/XM) installed
    • +4 = Analog Input (AUX/PR-UF0/UF1/UF2) installed
  • 0xxxxx?: Equipment II
    • +1 = Standard/Basic Value - Add to the Sum of Options below
    • +1 = TV-Tuner (PR-QV1/QV9) installed
    • +2 = CD-Changer or iPod/USB-Interface (PR-7A2/7A5/UF1/UF2) installed
    • +4 = Multi-Function-Steering Wheel (MFSW) installed
       

Adaptation

Channel 001: Tire Circumference

The tire circumference is being adapted in "mm".

Channel 002: Wheel Pulse

The wheel pulse describes the amount of wheel pulses per revolution.
If value 0 is entered the system calibrates automatically itself after several kilometers and inputs a value.

  • 43 = Audi A3 (8P) / Audi TT (8J)
  • 45 = Audi A4 (8E)

 

Channel 003: Language (Screen)

  • 0 = German
  • 1 = English (UK)
  • 2 = French
  • 3 = Italian
  • 5 = Spanish
  • 6 = Portuguese
  • 7 = English (UK)

 

Channel 004: Back-Up Camera

  • 0 = Back-Up Camera not installed
  • 2 = Back-Up Camera installed

 

Channel 005: Speed Threshold (Video Input)

  • 0 = max. 0 kph or 0 mph
  • 1 = max 5 kph (Standard for Europe)

 

Channel 007: Options

Channel 008: Volume Characteristic

Channel 010: Region

  • 0 = Europe/North America
  • 1 = Australia/South America
  • 2 = South Africa

 

Channel 011: Language (Speech Recognition)

  • 0 = German
  • 1 = English
  • 2 = French
  • 3 = Italian
  • 5 = Spanish

 

Channel 018: Start Screen

The start screen setting has to correspond with the control module coding, e.g. a S3 start screen doesn't work with an A4 coding.

  • 0 = Standard Start Screen
  • 1 = Audi S3 Start Screen
  • 2 = Audi S4 Start Screen
  • 3 = Audi RS4 Start Screen
  • 4 = Audi TT Start Screen
  • 5 = Audi R8 Start Screen

 

Channel 065: Read Test

Channel 066: Self Test

Channel 067: CD/DVD Drive

  • 000 - Normal/Eject-Button enabled
  • 001 = Eject CD/DVD (will not be saved)
  • 255 = Eject-Button disabled/locked (Anti-Theft-Protection)

 

Channel 068: Screen Test

Values will not be saved, they only act as initiation for each Test Picture.

  • 0 = No Test Picture
  • 1 = Test Picture: Red
  • 2 = Test Picture: Green
  • 3 = Test Picture: Blue
  • 4 = Test Picture: White
  • 5 = Test Picture: Black
  • 6 = Test Picture: Checkerboard
  • 7 = Test Picture: Checkerboard (inverted)
  • 8 = Test Picture: 64 Gray Scales (vertical Bars)
  • 9 = Test Picture: Special

 

Channel 069: Display Mechanism

  • 000 = Display closed
  • 001 = Display open
  • 200 = Display half open (Obstacle)
  • 255 = Position undefined

 

Channel 070: Display Brightness

  • 0 = 0% Brightness (Display OFF)
  • 1 = 20% Brightness
  • 2 = 40% Brightness
  • 3 = 60% Brightness
  • 4 = 80% Brightness
  • 5 = 100% Brightness

 

Channel 099: Transport Mode

Only applies to models without Gateway/Diagnostic Interface for Databus.

  • 0 = Transport Mode inactive
  • 1 = Transport Mode active

 

Channel 111: Reset

  • To perform a system reset/restart save 1 as new value.

 

Channel 114: FM Frequency

  • Range: 875...1080

 

Channel 117: Signal Test (Output)

  • 0 = Fader Center & Balance Center
  • 1 = Fader Front & Balance Left
  • 2 = Fader Front & Balance Right
  • 3 = Fader Rear & Balance Left
  • 4 = Fader Rear & Balance Right

 

Channel 136: Driver Position

  • RNS-E Basic
    • 03226 = Left-Hand-Drive (LHD)
    • 02632 = Right-Hand-Drive (RHD)
  • RNS-E High/US
    • 00005 = Left-Hand-Drive (LHD)
    • 00013 = Right-Hand-Drive (RHD)

 

Viele Grüße

Ulrich

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 10 Stunden schrieb Ulrich:

...

Eine Sache die mir sofort auffiel, das Navi startete nicht mit Zündung an und ging nach dem Ausmachen und Schlüsselabziehen nicht aus.

Ok muß ich halt am Knopf drücken für aus und ein.  Jetzt hatte ich gestern das Phänomen, dass das RNS-E  (Radio war an) plötzlich während der Fahrt aus ging. Hatte dieses beim alten RNS-E nur wenn ohne Zündung das RAdio an war..und das schaltete sich so nach 1/2 Stunde dann von selbst aus.

...

Viele Grüße

Ulrich

 

Du must dein RNS-E auf den A6 Modus umschalten.

Coding somit auf 05xxxx

Damit wird der CAN Befehlssatz im RNS-E auf den des A2 (auf dem z.B. Zündung an und aus übertragen wird)  umgeschaltet.

Alle weiteren Optionen natürlich dem bei die Verbauten optionen.

 

Muss umprogramiert werden, somit kannst du ja deinen alten RNS-E direkt auslesen und die Werte im neuen programieren.

 

Wenn hier wahrscheinlich noch der A3 eingestellt ist, kann irgend wann eine CAN-Befehlsfolge kommen, die der RNS-E dekodiert und ausführt, als Beispiel, du Ändersn die Instrumentenbeleuchtung und dein RNS-E geht aus.


VG

seinelektriker

 

  • Daumen hoch. 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 8 Stunden schrieb Ulrich:

habe nur diese Liste der Codierung gefunden

 

Codierung und noch viel mehr zum RNS-E findest du auch im A2 Wiki. ;)

 

  • Daumen hoch. 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@janihani

Zitat:  Codierung und noch viel mehr zum RNS-E findest du auch im A2 Wiki. ;)

 

Warum in die Ferne schweifen wenn das Gute liegt so nah!!

 

Danke für die Tips..werde das RNS-E erst einmal umkodieren!!

 

Gruß

Ulrich

 

 

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo...

 

kurze Rückmeldung..RNS-E auf audi A6 umcodiert..Jetzt funktioniert es so wie es sein soll.

 

Hatte erst direkt nach dem Codieren nicht funktioniert..nach einiger Zeit in laufenden Betrieb hat er es aber dann doch "gefressen".

 

Vielen Dank noch mal für die Unterstützung!

 

Gruß

Ulrich

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesem Inhalt zu folgen