Melde dich an, um diesem Inhalt zu folgen  
michael_k

Geräusch bei OBD-Verbindung

Recommended Posts

Hallo,

ich habe beim Experimentieren mit dem ELM-Interface eine merkwürdige Beobachtung gemacht. Versucht man, eine PID(standardisierte Adresse für eine bestimmte Information, z.B. Geschwindigkeit, Drehzahl usw.)

auszulesen, die der A2 nicht unterstützt, dann ertönt ein Geräusch, als würde die Klimaautomatik die Luftverteilung verstellen. Das lässt sich zuverlässig reproduzieren und tritt glaube ich auch bei völlig deaktivierter Klima auf.

Hat jemand mit einem Vag-Com oder einem anderen Interface schon mal so etwas beobachtet?

Nachdem das aufgetreten ist, ist der Bus tot(reagiert auf keine Anfragen mehr) und muss neu initialisiert werden.

Eine sehr unwahrscheinliches Gedankenspiel noch: Könnte es sein, das das Ganze durch einen Bug in der A2-Elektronik verursacht wird(es ist ja nicht normal, das bei einem fehlgeschlagenen Ausleseversuch der ganze Bus abstürzt) und dabei die Daten der Motorelektronik gelöscht werden?(Einspritztrimm langfristig usw.)

Ich bilde mir ein, nach einem solchen Versuch einen Leistungseinbruch bemerkt zu haben. Gleichzeitig hat mein A2 auf die letzte Tankfüllung 7,5 Liter verbraucht, trotz stets abgeschaltetem Klimakompressor und meistens ohne jede Beladung außer mir...

 

Gruß,

Michael

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo michael,

 

ich hatte mit meinem VAG-Com noch keinen derartigen Fehler erhalten. Beim Einschalten der Zündung mit angeschlossenem Diag-Stecker gibt es lediglich ein leises Klick aus Instrument, Zentralelektrik oder Lenkstockmodul (kann ich nicht lokalisieren). Die Steller der Klima bewegen sich nur dann, wenn ich die Klima auch anspreche. Wähle ich ein Gerät, das nicht existiert, gibt es lediglich keine Antwort. Abstürze gab es bisher nur auf dem Laptop und das Verhalten der Motorsteuerung ist nie beeinflußt worden. :]

Hat das von Dir genannte Interface eine Potentialtrennung? Liegen Fehler auf dem Motorsteuergerät ab?

 

Viele Grüße

aluholz

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Fehler stehen keine drin. Das Interface ist mit Sicherheit potentialgetrennt, es ist auch kein reines Pegelwandler-Interface, sondern enthält quasi das OBD-Protokoll(nur ISO9141-2 bzw. KWP2000 glaub ich) im Chip.

Siehe http://www.obd-2.de/prodst.html

Das Ding kann man mit jedem Terminalprogramm ansteuern.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesem Inhalt zu folgen