Jump to content

Probleme mit CAN-Bus Adapter - Steckerbelegung


Dynamike
 Share

Recommended Posts

Hi, seit kurzem bin ich stolzer Besitzer eines A2 Bj. 11/2000.

Als Radio möchte ich ein Concert II betreiben. Da der Audi keinen CAN-Bus Anschluss hat, funktioniert dies auch aktuell nur ohne die Features "Tastenbeleuchtung", "Betrieb nur bei eingeschalteter Zündungen" usw..

 

Ich habe nun folgenden CAN-Bus Adapter ersteigert:

eBay: Neue und gebrauchte Elektronikartikel, Autos, Kleidung, Sammlerst

Leider funktionieren die CAN-Bus Features nach der Installation des Adapters nach wie vor nicht.

 

Mich wundert, dass bei meinem A2 an "Stecker III" nur 3 Pins belegt sind. Nämlich...

"6 Beleuchtung (blau/grau)"

"7 Batterie + (rot/weiß)"

"8 Batterie - (braun)"

Steckerbelegung Audi / VW Autoradio

 

Kann jemand bestätigen, dass das so korrekt ist? Oder fehlen da bei meinem Stecker Kabel?

 

Wenn das so in Ordnung ist, würde ich davon ausgehen, dass der Adapter entweder defekt oder nicht für meinen Fahrzeugtyp geeignet ist.

 

Vielen Dank schon mal!

 

Michael

Link to comment
Share on other sites

Hi, der Anschaulichkeit halber habe ich ein Bild angehängt.

Da sind die Kabel grün markiert, die bei meinem A2 (ohne CAN-Bus) vorhanden sind. Wie gesagt funktioniert das Radio über diese Steckverbindung, natürlich ohne die CAN-Bus Features.

Mein Problem ist, dass sich das auch mit einem CAN-Bus Simulator der Marke "Kunset" nicht geändert hat. Weiss jemand, ob der weitere Leitungen, z.B. "3 - K-Diagnose" benötigt? Wenn ja, muss ich da die Leitung selber zum Radio führen? Von der Firma "Kunset" habe ich bisher leider keine hilfreichen Infos bekommen.

Danke!

Michael

 

Belegung_A2_ohne_CanBus.jpg

Link to comment
Share on other sites

Danke für die Infos. Ich hatte gehofft, dass ich keine Kabel ziehen muss, wenn ich einen "CAN-Bus-Simulator" verwenden. Ohne die K-Diagnose Leitung bringt der aber wohl nichts? Die Anleitung beim Adapter ist leider echt ein Witz!

Vielen Dank, das hilft mir schon mal sehr weiter.

Michael

Link to comment
Share on other sites

Ich stehe ja vor einem ähnlichen Problem. https://a2-freun.de/forum/showthread.php?p=925789#post925789

 

Bei mir ist auch nur Masse und Dauerplus in dem schwarzen Stecker angeschlossen. Bei deinem eBay Link sieht es aus, als ob die K-Leitung noch belegt wäre.

 

Hast du den grünen Stecker den eingesteckt?. Dazu muss der Originalstecker wie auf dem Bild zu sehen in C1-C3 zerlegt sein, oder du steckst sie in den vorhandenen Stecker.

Link to comment
Share on other sites

Hi Bigbmac, dein A2 hat fast die gleiche Erstzulassung. ;) Ich denke mal, das sind etwa die gleichen Voraussetzungen. Wie gesagt sind bei mir am schwarzen Stecker 3 Pins belegt. Scheinbar braucht der Kunset-Adapter noch die K-Leitung. Sind bei dir bei diesem Stecker auch nur die gleichen 3 Kabel? Für C1-C3 habe ich keinen Stecker. Den grünen Stecker von Kunset habe ich dementsprechend an C2 montiert. Ich werde jetzt mal überlegen, ob ich... A) nur die K-Leitung verlege und den Kunset-Adapter noch einmal ausprobiere... B) alle Kabel selber verlege und auf den Adapter verzichte... C) einen Adapter von "Kufatec" verwende. Da wird wohl nicht das Geschwindigkeits-Signal verwendet aber laut Support müsste der Adapter bei meiner Stecker-Belegung generell funktionieren. Sicher weiss man das natürlich erst, wenn man das ausprobiert hat. :/

Link to comment
Share on other sites

Am schwarzen Stecker sollten anliegen:

PIN 8 Masse

PIN 7 Dauerplus

PIN 3 K-Leitung

Das ist soweit richtig.

 

Meiner Meinung nach greift der Adapter das Signal der K-Leitung ab, verarbeitet es und gibt dieses in gewandelter Form über die Anschlüsse CAN-High und CAN-Low an das Concert auf Anschluss C2 weiter.

 

Edit: Wie bekommt man denn das angehängte Bild grösser? Im Original hat das 2500x1900 Pixel....

dsc01250hs3y.jpg.89e59b3a2f3980b70f5b3464f3523567.jpg

Edited by bigmac
Link to comment
Share on other sites

 

Edit: Wie bekommt man denn das angehängte Bild grösser? Im Original hat das 2500x1900 Pixel....

 

Wenn du wesentlich zu große Bilder anhängst (>1MB), dann rechnet sie das Forum kleiner und das passiert.

 

Verkleinere das Bild einfach auf sagen wir 1600x1216 und speicher es als JPG mit 80% Kompression, dann bist du vermutlich unter der Grenze.

 

Geht z.B. hiermit: Paint.NET - Free Software for Digital Photo Editing

Link to comment
Share on other sites

So, Adapter 2. Teil. Ich habe ja den Hersteller "Kufatec" vorab per Mail gefragt, ob der Adapter mit meiner Pin-Belegung laufen müsste. Das wurde bestätigt. Nun schließe ich das Teil an und... das gleiche Problem. Beim Email-Support war man plötzlich nicht mehr so gesprächig und gab keine Infos mehr, da ich den Adapter nicht direkt bei Kufatec bestellt habe, sondern bei einem Ebay-Händler. Also, nix Support! Ich Teile nun mittlerweile die Meinung... Finger Weg von CAN-Bus Adaptern. Der Service der beiden Firmen war wirklich eine Schande!

Ich werde nun die zwei CAN-Bus Kabel nächste Woche mal selber ziehen. Na hoffentlich klappts...

Link to comment
Share on other sites

So wie ich die dürftige Anleitung verstehe benötigt der Adapter von Kufatec neben der K-Leitung auch noch Zündplus an Pin4. Bevor ich diese zwei Leitungen verlege spare ich mir lieber den Adapter und lege die zwei CAN Bus Leitungen vom Kombiinstrument aus. Kommt aufs gleiche raus und ich habe 60 Euro gespart.

Link to comment
Share on other sites

Die beiden PIN's sind doch schnell angeschlossen! Kannst du die Anleitung mal posten?

Ich habe bei mir einen Adapterstecker zwischen Fahrzeug und Radio gesteckt, der normalerweise für Fremdradios benutzt wird. So kann ich einfach die benötigten PIN's umstecken.

Link to comment
Share on other sites

Hallo Bigmac, also bei mir gibt es definitiv nur Pin 6, 7 und 8. Zündplus und Kabel für Zündplus und K-Leitung sind nicht vorhanden. Bevor ich die jetzt irgendwoher umleite, schliesse ich jetzt lieber selber die zwei CAN Bus Kabel an.

Link to comment
Share on other sites

  • 2 weeks later...

Heute habe ich die zwei CAN-Bus Kabel vom Kombiinstrument zum Radio verlegt. Nun funktioniert alles prima. Die 50 bis 80 Euro für den CAN-Bus-Adapter kann man sich also wirklich sparen. Das Kabelverlegen ist relativ unproblematisch, dank Anleitung hier im Forum. Generell finde ich die Kunststoffteile am A2 allgemein etwas brüchig. Das liegt sicher auch an den 10 Jahren, die diese mittlerweile auf dem Buckel haben. Da bricht also schnell hier und dort mal ein Teil zur Befestigung ab. Von meiner Seite her, hätte Audi da gerne mehr Schrauben und weniger Plastik-Halter verwenden können. Nach dem Zusammenbau hält aber noch alles, daher will ich mich nicht beschweren.

Nach meinen schlechten Erfahrungen mit den CAN-Bus-Adaptern und dem grottigen Support der Hersteller würde ich also jetzt auch jedem raten, lieber die zwei CAN-Bus Kabel selber zu verlegen.

Link to comment
Share on other sites

Hi,

also mir haben folgende Einträge sehr geholfen:

 

Alu-Applikation Kombiinstrument nachrüsten - A2 Forum

... Da ist der Ausbau des Kombiinstruments ganz anschaulich erklärt.

 

Chorus 1 raus Concert 2 rein bei MJ 2001 - A2 Forum

... Da gibt es auf der zweiten Seite auch Fotos zu dem Stecker und den zwei CAN-Bus Kabeln.

 

Und natürlich der Link, den Karat21 hier gepostet hat...

Nochmal CanBus - A2 Forum

 

Ich hatte erst versucht die Leitungen über "Strobdiebe" bzw. Klemmverbinder abzuzweigen. Hat aber nicht wirklich gut funktioniert. Ich habe die Kabel dann mit einem scharfen Messer auf ca. 3 mm angeritzt, also die Leitung freigelegt. Dann Kabel anlöten, Isolierband herumwickeln... Die zwei Kabel habe ich auch wie beschrieben ordentlich "verdrillt". ;) Nun geht das prima.

 

Bei der Gelegenheit habe ich auch eine weitere Strombuchse und einen Adapter zum Ansteuern des CD-Wechsler-Eingangs verbaut. Da habe ich jetzt zwei Buchsen (Strom und Audio-In) bei der Ablage unter dem Aschenbecher. Das geht jetzt auch prima und man muss das Kabel, z.B. für ein Navi, nicht über die Handbremse legen.

Der Soundpegel über den Adapter ist im Vergleich zum Radio etwas leise. Das liegt vielleicht auch an meinem MP3 Player. Muss ich noch mal in Ruhe testen.

Generell hat das natürlich nichts mit dem CAN-Bus Problem zu tun... kann ich gerne noch einmal in einem anderen Thread beschreiben... wobei es da aber auch schon einige hilfreiche Einträge gibt.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Aktivitäten

    1. 24

      [1.2 TDI ANY] Sammelthread für Kupplungsnehmerzylinder mit Hall-Sensor-Umbau + HINWEIS!

    2. 21

      IT22

    3. 21

      IT22

    4. 21

      IT22

    5. 21

      IT22

    6. 9

      Fahrertür "lose"

    7. 85

      Getriebeölwechsel

    8. 3

      Tür rechts hinten verriegelt nicht mehr mit Zentralverriegelung

    9. 21

      IT22

×
×
  • Create New...

Important Information

Terms of Service here: Terms of Use, Privacy Policy here Privacy Policy and cookie information here: We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.