Jump to content

[1.4 AUA] Probleme mit AGR, Drosselklappe und MSG (Marelli Q)


Recommended Posts

Hallo liebe A2-Freunde,

 

nachdem ich bisher immer nur mitgelesen und Informationen gesucht habe, muss ich heute leider doch mal selbst einen Beitrag verfassen und um Hilfe bitten. :/

 

Kurze Randinfo zum Auto:

Audi A2 (A2 1.4 R455 M5S), BJ 01.09.2000, MJ 2001; EZ 27.02.2001; bei uns seit 03/2003, vorher Jahreswagen beim Autohaus)

  • MSG (MARELLI 4LV  3415; 036 906 034 Q)
  • Bremsenelektronik (ESP  20  CAN  V015; 8Z0 907 379 B)
  • KI (W1-KOMBIINSTR. VDO D13; 8Z0 920 900 AX)
  • KSTG (Komfortger·t T04  03B1; 8Z0 959 433 H)

 

Nachdem wir uns die Jahre nicht selbst drum gekümmert haben, sondern immer bei Problemen zum AH oder Freundlichen gegangen sind, haben wir seit ende letzten Jahres uns auch selbst ans Auto gewagt und mein Vater gleich noch die halbe Werkstattausrüstung dazugeholt :bonk:

 

Jedenfalls krempeln wir aktuell das Auto komplett um und machen es "Liebhaber"-Fit und nicht nur "Fahrtauglich und Hauptsache HU bestehen"-Fit.

Das heißt bisher: Bremsen alle neu, Radlager neu, ABS-Sensoren neu, Spurstangenkopf neu, Bremsleitungen gebördelt, Bremszylinder ersetzt, Benzinfilter ersetzt, Innenraumgebläse erneuert, Luftfilter gewechselt, und und und... alles seit Nov 2020.

 

Jedoch wollten wir uns jetzt mit dem neuen VCDS auch an ältere Probleme mal herantasten, die u.a. schon seit 2015 bestehen.

 

1. Motorlampe, ruckeln, kein sauberer Leerlauf

Problem begleitete uns gefühlt schon sein Anfang an, ging aber früher immer (wg. VW-Versicherung) in die Werkstatt und es wurden gefühlt jedes Jahr die Lambdasonden gewechselt. Irgendwann war Ruhe und dann ging es wieder los, dass sporadisch die MKL anging. Wie gesagt 2015 beim Freundlichen gewesen, alles durchgecheckt. Zahnriemen wurde von der Werkstatt damals falsch aufgezogen, hat alles richtig aufgezogen und es ruckelte weniger im Standgas. Drosselklappe machte faxen, wurde zusammen mit AGR gereinigt und am Ende erneuert. Fehler war damals "Gemisch zu fettig" und "Zündaussetzer xxx" soweit ich mich erinnere.

 

Finaler Stand damals: Drosselklappe neu, lies sich aber nicht am MSG anlernen und das MSG auch nicht updaten.

Finaler Stand heute: Drosselklappe gereinigt (versüfft wie sau), Durchgemessen und überprüft (Motor funzt, Poti zeigen auch richtige Werte), anlernen wie bisher immer Fehlgeschlagen (Feld 4 "ERROR)

Fehlerspeicher:

17989 - Drosselklappensteuereinheit (J338) 
            P1581 - 35-00 - Grundeinstellung nicht durchgef¸hrt
17962 - Drosselklappensteuereinheit (J338) 
            P1554 - 35-10 - Bedingungen f¸r Grundeinst. nicht erf¸llt - Sporadisch
Readiness: 0010 0101

 

Grundeinstellung 060:

  8.7 %  Drosselklappen- winkel (G187)
  9.3 %  Drosselklappen- winkel (G188)
  2.0  Lernschrittzähler 
  ERROR  Status der Anpassung

 

Grundeinstellung hat sich aber - seltsamerweise - nach kurzer Fahrt zum anwärmen und start des Readiness-Setzens durchführen lassen. 060 - 5 sek warten - ADP i.O.

Wie im Reparaturleitfaden angegeben 30 sek. Zündung aus - Fehlercodes ausgelesen - alles i.O.!

 

Nachdem wir dann den Readiness-Code komplett gesetzt haben, kurz Kaffeetrinken gewesen, 30 min später wieder FC ausgelesen - erneut: "17989 - Drosselklappensteuereinheit (J338)  P1581 - 35-00 - Grundeinstellung nicht durchgef¸hrt"

Und dann konnte wieder die Grundeinstellung nicht erfolgen - Feld 4 "ERROR"

 

2. AGR-Ventil Grundeinstellung

Danach der nächste Versuch mit dem zurücksetzen der Lernwerte. Siehe da - AGR-Ventil und DK keine Grundeinstellung durchgeführt.

Wieder die selbe Prozedur wie oben - DK nicht möglich. AGR-Ventil Grundeinstellung versucht - auch nicht möglich. Feld 4 springt immer von "TEST AUS" zu "TEST EIN" und vice versa.

Wieder den Readiness einstellen wollen, bis zum AGR-Ventil alles i.O. Danach wieder Drosselklappe - siehe das "ADP i.O." Zurück zur Readiness und seltsamerweise klappte auch nach einiger zeit das mit dem AGR, aber Meldung war "n.i.O." da die Druckdifferenz anscheinend mit "58 mBar" zu niedrig war. Readiness zeigte aber trotzdem "0000 0000". A2 1 Minute schlafen lassen und wieder eingeschaltet - Fehlercode DK Grundeinstellung und mehr nicht. Readiness war erneut bei "1110 0101"

 

Da das AGR-Ventil aber sowieso von außen sehr bescheiden aussieht, bauen wir nächste Woche ein neues AGR  N18 und einen neuen Saugrohrdrucksensor G71 ein.

 

3. Motorsteuergerät

Das heißt, er nimmt zwar irgendwie die beiden Werte an und speichert diese ab, jedoch "vergisst" er sie nach einiger Zeit wieder. Könnte das auf ein defektes MSG hinweisen?

Wir hatten das Auto zwischendurch noch in einer anderen Freien Werkstatt gehabt, die meinten das MSG ist defekt und müsste ausgetauscht werden und nach 3 Wochen hab ich den wieder bekommen, mit der Aussage, dass ein neues MSG verbaut wurde und jetzt alles funktioniert. Dauerte knapp 1 Monat, dann kam wieder meine schöne MKL zum Vorschein.

 

3.1 MSG ersetzen

Wir überlegen, ob es sinnvoll ist ein gebrauchtes MSG (nicht-updatefähig) zu holen und das zu ersetzen? Müssen wir halt leider in die Werkstatt wegen der Login-Codes, aber das nutzt ja dann leider nichts.

3.2 MSG erneuern

Wäre es denn möglich, ein anderes MSG (updatefähig) zu besorgen und das anzulernen? Oder wäre das beim AUA schier unmöglich?

 

Soweit war's das erstmal von meiner Seite her mit den Fragen:chair:

 

Ich hoffe ich hab nicht vergessen.

 

Viele Grüße und Danke schon mal im Voraus,

Phillip 

Edited by serst_phil
Link to post
Share on other sites

Hallo,
bei mir war die Motorkontrollleuchte erst aus, nachdem ich den Ölabscheider, also Kurbelgehäuseentlüftung erneuert hatte (nach Lambdasonden und Drosselklappenreinigung usw.). Seitdem bleibt die MKL aus, schon seit einigen tausend Kilometern!

MfG

Winkeleisen

Link to post
Share on other sites

Aktuell ist die MKL dauerhaft aus, seit wir auch beide Lambdasonden gewechselt haben (haben auch gleich den Auspuff mit gemacht). Diesbezüglich haben wir (erstmal) gerade keine Sorgen - die waren nach 4 Jahren Stop-and-Go mit der MKL endlich vorbei. Aber jetzt haben wir uns an das Thema der DK gemacht und verzweifeln da gerade ein wenig.

 

Viele Grüße,

Phillip

Link to post
Share on other sites
vor 25 Minuten schrieb serst_phil:

Das heißt, er nimmt zwar irgendwie die beiden Werte an und speichert diese ab, jedoch "vergisst" er sie nach einiger Zeit wieder. Könnte das auf ein defektes MSG hinweisen?

 

Zumindest ist es nicht normal.

 

vor 26 Minuten schrieb serst_phil:

die meinten das MSG ist defekt und müsste ausgetauscht werden und nach 3 Wochen hab ich den wieder bekommen, mit der Aussage, dass ein neues MSG verbaut wurde und jetzt alles funktioniert.

 

Ich frage mich, wie die das geschafft haben, die WFS anzulernen? Aber auch eine Hinterhofwerkstatt kann sich belesen, sich die notwendige Hard- und Software beschaffen, und dann die WFS anlernen. Sie müssen nur den Logincode vom "neuen" MSG haben. Ich denke eher, die habe es mehrmals probiert, die DK anzulernen und waren froh, den A2 irgendwann an dir übergeben zu können.

 

Wenn du mit dem Gedanken spielst, die ein anderes MSG zu holen, dann nimm eins, das auf EG endet und somit auch updatefähig ist.
Gut wäre, wenn der Verkäufer den Logincode aus dem KI auslesen könnte, aber das können die meisten nicht.

 

Da ich im Zuge meiner beiden Motorenumbauten ein MSG vom Polo 9N und eins aus einem Skoda Fabia 6Y in den A2 eingebaut habe, sollten auch diese funktionieren. Möglicherweise sind diese besser und günstiger zu bekommen. Schau dir die Links in meiner Signatur an.

 

 

  • Like 2
Link to post
Share on other sites
  • Nagah changed the title to [1.4 AUA] Probleme mit AGR, Drosselklappe und MSG (Marelli Q)

Moderator:

Bitte das Problem in der Überschrift nur knapp beschreiben und Details im Text. Ich habe daher die Überschrift angepasst.

 

- Nagah

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms of Service here: Terms of Use, Privacy Policy here Privacy Policy and cookie information here: We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.