Jump to content

[1.4 AUA] Motorkontrolleuchte erst da, dann wieder weg; auslesen per OBD nicht möglich


Recommended Posts

Hallo zusammen,

 

am Sonntag hat bei mein 1.4 AUA nach ca. 2km Fahrt die Motorkontrolleuchte aufgeleuchtet. Ich bin die 2km zurück gefahren und habe versucht mit meinem universal OBD Auslesegerät (icaroft) den Fehler zu konkretisieren. Leider ohne Erfolg: "Kommunikation mit dem Fahrzeugsteuergerät ist nicht möglich". Ich habe keine Symptome am Motorlauf bemerkt.

 

Nun stand er 3 Tage und heute bin ich zu einem Kollegen gefahren der ein anderes Auslesegerät hat, leider auch damit ein fast gleichlautende "Fehlermeldung", dass kein Kontakt zum Fahrzeugsteuergerät möglich ist.

 

Beim Anlassen für den Heimweg war die Motorkontrolle weg (ca. 5 Starts nach dem ersten Aufleuchten und ca. 3km Fahrt).

Auslesen funktioniert immer noch nicht, bei anderen VAG Fahrzeugen habe ich kein Problem.

 

Mir scheint, dass es sich um zwei voneinander unabhängige Probleme handelt und ich die MKL erstmal MKL sein lasse, bis sie wieder leuchtet.

 

Hat jemand eine Idee woran das Problem bei der (nicht möglichen) Kommunikation per ODB liegen kann?

 

Grüße Aaron

 

Link to post
Share on other sites

Ich habe selbiges Problem ebenfalls mit mehreren OBD-Geräten gehabt.

Einige Fehler wurden angezeigt, einige nicht.

Und zurücksetzen kann man mit den OBD-Geräten nur die ganz banalen Sachen.

Ich denke, man kommt bei VAG Fahrzeugen um ein VCDS-Gerät nicht herum.

Auch weil viele "kleine" Fehler gar nicht angezeigt werden, sondern nur als Mitteilung des VCDS herauskommen.


Vor ein paar Wochen hatte ich auch MKL und damals den ADAC kommen lassen.

Diagnose: Lambda-Sonde 1.

Zurückgesetzt, Motor an, 5 Minuten laufen lassen, MKL seitdem dauerhaft aus.

Kommentar vom ADAC: Da reicht ein falscher Impuls aus, weil ein Rußpartikel die Sonde kurzzeitig behindert hat und die MKL geht an. Kaputt ist dann nichts, aber die MKL bleibt an.


Der hatte dann auch noch eine "kleine" Meldung, daß es mal/sporadisch Aussetzer bei der Spannungsversorgung der Kraftstoffpumpe gegeben habe, was aber nicht zu einem Fehler/Aussetzer geführt hat.

Link to post
Share on other sites
Posted (edited)

Falls Auslesen bei diesem Auto gar nicht geht würde ich Mal die Sicherung für die Diagnose-Dose durchmessen oder einfach tauschen. Bei gealterten Sicherungen bricht manchmal der Leiter, mit bloßen Auge ist das kaum zu erkennen.

Edit: Sicherung 28

Edited by Sepp
  • Like 1
Link to post
Share on other sites
vor 21 Minuten schrieb Sepp:

Falls Auslesen bei diesem Auto gar nicht geht würde ich Mal die Sicherung für die Diagnose-Dose durchmessen oder einfach tauschen. Bei gealterten Sicherungen bricht manchmal der Leiter, mit bloßen Auge ist das kaum zu erkennen.

Hallo,

zunächst Danke für den informativen Hinweis. Wäre das nur Sicherung 28 oder zusätzlich auch 29. An letzterer hängt ja auch der Rückfahrscheinwerfer, der dann nicht leuchten dürfte.

Grüße Kalla

  • Like 1
Link to post
Share on other sites

Ja danke, guter Hinweis. Der Zündungsplus (KL15) für die Diagnose-Dose liegt auf S29. Wenn die durch ist geht der Rückfahrscheinwerfer nicht. Zusätzlich wie gesagt S28 kontrollieren.

  • Like 1
Link to post
Share on other sites

Hallo, Danke schonmal für eure Hinweise!

 

Das diese Universal OBD Auslesegeräte eine eingeschränkte Funktionalität haben ist mir bekannt. Bis jetzt hat es für mich aber immer gereicht. Ich kann an einer Hand abzählen wie oft ich Fehler am A2 ausgelesen habe und dann hat die OBD Diagnose immer sehr geholfen den Fehler konkret einzugrenzen. Ich die Anschaffungskosten für VCDS immer gescheut.

 

Die Sicherungen 28 und 29 haben Durchgang und die Kontakte sehen nicht korrodiert. Soweit ich das verstehe dürfte, wenn die Sicherungen durch sind das Gerät auch gar keine Stromversorgung erhalten, oder? 

 

Das Diagnosegerät bekommt auf jeden Fall Spannung, die "Verbindung" nach ISO9141 wird auch mit eine "ok" quittiert.

Bei dem Versuch Fehler bei auszulesen kommt dann die Meldung, dass eine "Kommunikation mit dem Fahrzeugsteuergerät nicht möglich" ist.

 

Bei mehreren anderen VAG Fahrzeugen kommt bei gleichem Ablauf die Meldung, dass keine Fehler im Fehlerspeicher vorhanden sind. Bis jetzt hat das bei A2 (zuletzt vor ca. einem Jahr) definitiv genau so funktioniert.

 

Wäre der nächste der Gang in eine Werkstatt mit der Frage ob bei denen die Kommunikation durch VCDS funktiniert?

Oder hat jemand im Raum Nürnberg oder München die Möglichkeit es für mich mal mit VCDS zu versuchen?

 

Grüße Aaron

 

WhatsApp Image 2021-05-13 at 17.17.28.jpeg

WhatsApp Image 2021-05-13 at 17.17.28 (1).jpeg

Link to post
Share on other sites

Der Hinweistext "ISO9141 ok" besagt dass das Diagnosegerät eine Verbindung mit dem Kombiinstrument über K-Line aufbauen kann. Möglicherweise routet das Kombiinstrument nicht weiter z.B. zum Motor-SG. Dann hast Du spätestens bei der nächsten HU ein Problem. Ich würde mal checken ob das mit anderen Diagnosgeräten funktioniert, z.B. in einer freien Werkstatt.

Link to post
Share on other sites
vor 12 Minuten schrieb Sepp:

Dann hast Du spätestens bei der nächsten HU ein Problem.

 

Daran habe ich tatsächlich auch schon gedacht. :(

 

vor 13 Minuten schrieb Sepp:

Ich würde mal checken ob das mit anderen Diagnosgeräten funktioniert, z.B. in einer freien Werkstatt.

 

Ich war schon bei 2 Bekannten die ähnliche "semi professionelle" handheld Diagnose Geräte haben. Bei beiden Fehler mit ähnlich lautendem Wortlaut.

 

Ist dann noch irgendwie was zu machen, oder kann ich schon anfangen mich nach nem Kombiinstrument und jemandem der mir das codiert umzuschauen?

:S

Link to post
Share on other sites

Nachtrag: Ich schau morgen auf jeden Fall mal ob ich "meinen" selbständigen VAG/Audi Schrauber erwische. Der ist leider so gut und deswegen auch so beschäftigt, dass es schwierig ist von ihm ein paar Minuten zu bekommen.

Link to post
Share on other sites
vor 2 Stunden schrieb A.S.:

Bei dem Versuch Fehler bei auszulesen kommt dann die Meldung, dass eine "Kommunikation mit dem Fahrzeugsteuergerät nicht möglich" ist.

 

vor 1 Stunde schrieb A.S.:

Ist dann noch irgendwie was zu machen, oder kann ich schon anfangen mich nach nem Kombiinstrument und jemandem der mir das codiert umzuschauen?

 

Wieso Kombiinstrument?
Bei der Meldung "Kommunikation mit dem Fahrzeugsteuergerät nicht möglich" würde ich doch das Motorsteuergerät annehmen und nicht das Kombiinstrument.

Link to post
Share on other sites

Moin,

 

ich habe zwar einen BAD, aber das kommen und gehen der MKL ist bei Sporadischen Fehler normal. Bei mir war es eine defekte alternde Einspritzdüse die Sporadische Aussetzfehler für einen Zylinder gemeldet hat.

Zuerst nur als Fehler im MSTG, dann die an und ausgehende MKL bis zum dauerleuchten der MKL.

 

Und ja, es muss das MSG abgefragt werden, nicht das KI, denn die MKL ist im KI nur eine Lampe (LED) die vom MSTG angeeuert wird.

 

Zu deinen Kommunikationsproblemen, nicht nur ein Protokoll muss der Tester können, auch Anpassungen der Auslesegeschwindigkeit (Takt) wie auch Wartezeiten können von STG zu STG variieren.
Ein und das gleiche Protokoll kann somit bei unterschiedlichen STG funktionieren und nicht.

 

Und z.B. beim MSTG des ATL ist ab einer bestimmten Fahrzeuggeschwindigkeit keine Kommunikation mehr möglich, das ist aber auch so richtig.

 

 

Link to post
Share on other sites
vor 2 Stunden schrieb A.S.:

Ich schau morgen auf jeden Fall mal ob ich "meinen" selbständigen VAG/Audi Schrauber erwische.

Wenn Du auslesen lässt, lass mal prüfen in welche weiteren Steuergeräte (Kombiinstrument, Klima) man da mit dem Diagnosegerät reinkommt. Die Botschaften werden ja zunächst ans Kombi gerichtet und von da aus an die weiteren Steuergeräte weiterverteilt. Wenn dieses Weiterverteilen nicht klappt z.B. weil das Relais im Kombi einen weg hat dann kommt man auch nicht ins MSG.

 

Geht der Drehzahlmesser? Falls ja kann man ein defektes MSG ausschliessen denn dann spielt das MSG korrekt auf dem CAN-Bus mit.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Aktivitäten

    1. 2

      Kunststoffring - Unterer Kühlmittelschlauch - TDI

    2. 2

      Kunststoffring - Unterer Kühlmittelschlauch - TDI

    3. 3

      Jubiläumstour des Audi Club Nürnberg e.V. am 07.08.2021

    4. 20

      Funkschlüssel synchronisieren?

    5. 5674

      Der "ich habe 'ne kurze Frage" Thread

    6. 5674

      Der "ich habe 'ne kurze Frage" Thread

    7. 5674

      Der "ich habe 'ne kurze Frage" Thread

    8. 5674

      Der "ich habe 'ne kurze Frage" Thread

    9. 2

      Aussenspiegelglas demontieren?

    10. 5674

      Der "ich habe 'ne kurze Frage" Thread

×
×
  • Create New...

Important Information

Terms of Service here: Terms of Use, Privacy Policy here Privacy Policy and cookie information here: We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.