Jump to content
Aus Sicherheitsgründen ist eine Anmeldung nur noch mit der hinterlegten E-Mail Adresse möglich. ×

VAG-COM erkennt Motorsteuergerät nicht


Norman
 Share

Recommended Posts

Habe mir den GRA-Nachrüstsatz von Cum-Cartec kommen lassen und gleich das Interface mitbestellt, weil ich mir die Freischaltung sparen wollte. Die VAG-COM 311 ist als Shareware-Version auf dem Notebook (Win XP), der USB-Treiber von der mitgelieferten CD. Die GRA ist noch nicht eingebaut, das Auto also bislang unangetastet.

 

Einige Steuergeräte werden erkannt, wie z.B. das Radio oder die Klimaautomatik. Leider aber bekomme ich beim Motorsteuergerät immer die Anzeige, das Programm könne keine Verbindung aufbauen. Er testet zwar immer alle Baud-Werte durch, bekommt aber keine Antwort.

 

Hat wer schonmal ein solches Problem gehabt?

Link to comment
Share on other sites

dann ist sehr wahrscheinlich, dass der USB-COM Umwandler in deinem Adapter keine krummen Baudrates wie 10472 unterstützt; Radio und Klima lassen sich anscheinend mit herkömmlichen 9600 anspechen, MSG aber mit 10472 o.ä., was das Ding nicht kann

ich würde erstmal mit Einstellungen der COM-Port auf dem Rechner und im VAG-COM spielen; wenn es nichts bringt - dann geht es in dieser Konfiguration halt nicht :)

Edited by Lau
Link to comment
Share on other sites

Mit welcher Baud-Rate kommuniziert den das MSG?

es müssen 9600 oder 10472 sein; das ist aber in diesem Sinne nicht ausschlaggebend; laut VAG-Protokoll wird die Kommunikation mit der Baudarte 5 (fünf) initialisiert, d.h. das Steuegerät muss erstmal ein Paar Bytes (bin zu faul nachzuschlagen welche) mit Baudrate 5 empfangen, dann antwortet er und schatlen die beiden Seiten auf die "standard"-Baudrate wie 9600; es kann durchaus sein dass bei dieser Initialisierung (angenommen dein Adapter schafft das Timing bei 5 Baud nicht richtig) die Firmwares von Radio oder Klima toleranter sind als von dem Motorsteuergerät, das einfach kein Init sieht

Link to comment
Share on other sites

nur mal als tipp, keine ahnung ob es funktioniert.

 

Bei meinem A3 hatte ich dasselbe problem und da hat es geholfen während des Verbindungsversuchs die Zündung anzuschalten. Dann hat er es immer gefunden... wie gesagt, versuchen kann man es ja

Link to comment
Share on other sites

nur mal als tipp, keine ahnung ob es funktioniert.

 

Bei meinem A3 hatte ich dasselbe problem und da hat es geholfen während des Verbindungsversuchs die Zündung anzuschalten. Dann hat er es immer gefunden... wie gesagt, versuchen kann man es ja

 

Ich weiß ha nicht ob das nur für den A3 gilt. Beim A2 braucht man Zündung "an", damit die Steuergeräte ansprechbar sind.

 

@Bluefalke

Stelle mal als Baudrate im VAG-Com 9400 (9600) ein. Bei mir ging es einfach mit 0 (standard) nicht.

Link to comment
Share on other sites

Genau das ist ja timmys Trick. Zündung erst anschalten wenn die Software grade versucht (zum ersten mal) auf das STG zu kommen. Die Software versucht es 3x - bis sie beim letzten Versuch angekommen ist, ist das Steuergerät oben. Kann schon sein, dass der Trick funktioniert...

Link to comment
Share on other sites

So war das gemeint, muss man auch erst mal wissen :D. Dieses Problem hatte ich zum Glück nicht. Wenn ich nur wieder an meine Klima zum auslesen rankommen würde. Naja werde halt noch bis ende März warten müssen.

Link to comment
Share on other sites

Also die Tipps werde ich gleich morgen mal probieren.

@tichy: Wenn alle Stricke reißen, rechne ich mir mal aus, ob die Werkstatt oder die Strecke billiger sind und komme dann ggf. (sprichwörtlich) auf Dich zu.

 

Hier überigens die Antwort von Cum-Cartec:

Hallo,

 

leider kommt es beim A2 manchmal vor, das bereits eine neuere Motorelektronik verbaut wurde.

Leider können Sie dann nicht auf die Motorelektronik zugreifen.

 

Mit freundlichen Grüßen

 

M. Hahnen

Link to comment
Share on other sites

Mir fällt dazu nur immer wieder ein:Wer billig kauft - kauft zweimal.

 

Ich würde wenn dann immer gleich ein originales Rosstech Interface kaufen. Oder halt in die Liste schauen und jemandanden in der Nähe um Hilfe bitten.

 

Mütze

Link to comment
Share on other sites

Guest ca3sium

So kann man das auch nicht sagen, bei mir funktioniert das billig-VAG-COM eigentlich sehr gut.

Nur die Klimaanlage kann ich damit nicht auslesen.

 

In Verbindung mit WBH-Diag kann man auch die einzelnen Anpasskanäle anfahren.

 

Natürlich ist ein echtes Ross-Tech Gerät eine feine Sache, kostet aber auch.

 

Für Stellglieddiagnosen habe ich noch das Diadig S101, damit bin ich eigentlich voll ausgerüstet. Und das ganz ohne Ross-Tech.

Link to comment
Share on other sites

Hast Du ein neueres Telefonsteuergerät? Das geht auch nicht mit den "einfachen" Adapter und der Shareware. Wenn ein neues Steuergerät auf dem Markt ist, geht die Anpassung bei Rosstech sehr schnell. Eine neue Firmware wird dann für das Kabel zur Verfügung gestellt und man es dann auch für das neue Nutzen.

Des weiteren ist in der Software nun auch schön die Labeldateien und Kodiertabellen hinterlegt. Messwertblöcke sind ordentlich beschrieben mit Sollwerten, so kann man schneller einen Fehler eingrenzen. Auch die Kodierhilfe für Steuergerät mit langer Kodierung ist sehr gut, einfach die Bits anklicken und dann wird die Neue Kodierung übernommen. Da träumt selbst der Freundliche von!

Ich habe den Stress mit dem Billigteilen selber durch und und bleibe bei dem Spruch von Oben!

Da werden Steuergeräte nicht erkannt, oder lassen sich nicht anwählen, dann kann man keine Kodierung reinschreiben ..... Alles extrem nervig.

 

Klar ist VAGCOM teuer, aber nicht überteuert für das was es bietet. Ich habe die Software nun schon seid ein paar Jahren im Einsatz und noch nie für ein Update zahlen müssen!

 

Mütze

Link to comment
Share on other sites

Mir fällt dazu nur immer wieder ein:Wer billig kauft - kauft zweimal.

das hat mit billig erstmal überhaupt nichts zu tun; wenn der Themenstarter sich einen Rechner mit echter COM-Schnittstelle und einen COM-basierten K-Line Adapter besorgt dann wird es auch mit den geknackten 3.11 oder sogar 4.09 Versionen einwandfrei funktionieren; für 'ein neueres Telefonsteuergerät' reicht es vielleicht mangels neuer Label-Files nicht aus, für alle Standard-Elektronik die im MJ2004 verbaut wurde aber schon

Link to comment
Share on other sites

Ich schick den Kram jetzt zurück und bekomme auch mein Geld dafür wieder (hoffentlich). Dann muss ich wenigstens nicht zweimal kaufen.

 

Freischalten tut jetzt mein :). Der Einbau der GRA ist so teuer, dass mich das Freischalten kaum noch jucken wird.

Link to comment
Share on other sites

  • 2 months later...

 

Stelle mal als Baudrate im VAG-Com 9400 (9600) ein. Bei mir ging es einfach mit 0 (standard) nicht.

 

Danke für den Tip, es klappt sehr gut. Konnte bisher mit meinem No-Ross Interface das Motorsteuergerät MARELLI nicht auslesen.

 

lt. OBDforum.org bei Problemen mit "kann Baudrate nicht synchronisieren" bei 9600 beginnen, dann 4800, 2400 und 1200 als feste Baudrate in den Optionen des VAG-Com eintragen. dazwischen 1x Zündung aus/ein.

 

Vielleicht klappts auch so mit dem Klimagerät?

 

:cool: Möchte damit nicht die Qualität der Ross-Interfaces untergraben. Da heißt`s halt einstecken und gut is.:cool:

 

Gruß

Surfsound

Link to comment
Share on other sites

Guest ca3sium

Das klappt auch mit dem Klimasteuergerät, da konnte ich früher nicht zugreifen, nach ein paar Minuten Baudrate stellen hat es dann geklappt.

Link to comment
Share on other sites

@ca3sium kannst Du mir mal einen Tip geben?

 

hab`s heut versucht:

 

Klimagerät schaff ich nicht, kannst Du hier die eingestellte Baudrate bzw. Dein Vorgehen beschreiben.

 

Meins war 9600/9400/4800/2400/1200 dazwischen Zündung ein/aus. Mein größter Erfolg war die Anzeige Klimavollautomatik 0514. Dann ändert VAG-Com irgendwas und bringt nach kurzer Zeit "zu viele Übertragungsfehler".

 

@All: Wie taktet die Baudrate im Standard bei VAG-Com durch bzw. was wird da im Protokoll ständig gewechselt? Nur interessehalber.

Link to comment
Share on other sites

Hast du in den Optionen die Einstellungen zur Reduzierung der CPU-Last angehakt? Wenn ja, mach mal raus.

 

Ein original VCDS verbindet sich mit 4800 Baud auf das Klimasteuergerät.

 

Klimabedienteile sind bekannt dafür, dass sie nicht mit jedem beliebigen Interface ausgelesen werden können. Probleme machen hier die Anbindung des Interface über USB und ggf. auch der Laptop selbst. Wenn das Interface selbst billige Elektronik ist, liefert es ggf. zu geringe Datenübertragungsqualität.

Link to comment
Share on other sites

  • 7 years later...

VAG COM und VCDS Baudrate 4800 und es geht :D Danke für die Tipps

Noch mal zu den ganzen Sensoren, solange die nicht ganz kaputt sind und nur falsche Werte geben, werden sie im Fehlerspeicher nicht angezeigt !!!! Da hilft nur abziehen und schauen ob sich was verändert. Danach natürlich Fehlerspeicher löschen !!!!!!

Edited by Transistor_61
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

Terms of Service here: Terms of Use, Privacy Policy here Privacy Policy and cookie information here: We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.