TDI-Düser

Probleme bei FIS Nachrüstung (Kombiinstrument Dump)

Recommended Posts

Guten Abend Zusammen,

ich habe ein Kombiinstrument mit FIS gekauft, von dem ich leider kein Login-Code habe. Das heißt ich kann es nicht ohne Weiteres einbauen (Online Abfrage beim Freundlichen sollte möglich sein, da die Fahrgestellnummer bekannt ist).

 

Nun habe ich aber etwas recherchiert und mir die Binär-Daten vom EEPROM mittels eines Programmieradapters ausgelesen (Den Adapter benutze ich sonst eigentlich bei Mikrocontroller Basteleien...). Leider bin ich nicht in der Lage die Daten richtig zu interpretieren. Eventuell kann mir da jemand helfen den Dump zu interpretieren, bzw. den Login auszulesen.

 

Bitte Info per PN, wer sowas kann, dann würde ich kurz die Daten schicken.

 

Beste Grüße

TDI-Düser

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Danke für den Link, da hab ich auch schon gelesen:III:. Leider steht an der Stelle im Dump nicht 3x das gleiche, es steht 1B 1D 9F 30 B3 06. Ist den das bei whoopsie auf der Seite allgemeingültig, auch für das A2 Kombiinstrument?

 

Habe das EEPROM komplett von der Platine entlötet, sind die EEPROMs beim A2 verschlüsselt?

 

Gute Nacht

dump_ausschnitt.PNG.9ab157a7b1b5bd6777ef4e016b262fd9.PNG

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich meine die EEPROMs sind je nach Hersteller und Ausführung verschieden, bzw die Infos stehen an verschiedenen Stellen.

Am einfachsten lässt sich sowas mit vag dash can, oder can commander auslesen, bzw auch gleich wieder anpassen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Das ist in meinen Augen unlogisch: Da man direkt die Adressen ausliest muss der Inhalt gleich sein. Einzig bei unterschiedlichen Typs von EPROM (Bitlänge, Speichergröße) ist dies logisch, aber ob nun TI oder Motorola - der Hersteller ist egal. Wie heißen denn die EPROMS? Notfalls ins DS schauen, wie die organisiert sind.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Herstellerlogo ist ein kleines "f", EEPROM ist ein 93C86, siehe Bild.

 

Gibt es jemanden hier im Forum der entsprechende Programme hat?

Bitte eine kurze PN...

 

Grüße

TDI-Düser

Bild_EEPROM.PNG.9ccfd8e691ef7921635a5d314f993c95.PNG

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Habe beides probiert (EEPROM ist dabei nicht zu Schaden gekommen!), ich gehe davon aus, das es 16 bit organisiert ist, bei 8 bit stehen kaum Daten im EEPROM...

 

Auszug Datenblatt Microchip:"When ORG is connected to VCC, the x16 memory organization is selected. When ORG is tied to VSS, the x8 memory organization is selected. There is an internal pull-up resistor on the ORG pin that will select x16 organization when left unconnected."

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Achso, bitte auf der Platine messen / gegen Pin8=Vcc=High=16bit

Pin5=Vss=Low =8bit

nichts von beidem=16bit

 

Ich würde aber auch 16bit annehmen, außer der Prozessor kann Pin 5 schalten und wahlweise 8bit oder 16bit nutzen [emoji30]

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ok, dann werden wir irgendwann durch Dich wissen, wo der Code steht [emoji6]

Spaß beiseite, ich habe folgendes bisher gefunden:

Am Ende des Files als DEC

Verschlüsselt im File als HEX, wobei die 2. Hex Reverse sind (09 54 ist dann 54 09)

trifft leider alles nicht auf Deinen Ausschnitt zu, auch nicht eine Zeile tiefer an der von Dir beschriebenen Adresse

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Denke mal, dass der dump schrott ist. Normalerweise erkennt man rechts paar Zeilen drüber FIN und immo-Daten, wenn er OK ist.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Denke mal, dass der dump schrott ist. Normalerweise erkennt man rechts paar Zeilen drüber FIN und immo-Daten, wenn er OK ist.

 

 

 

Die Hex-Werte sollten stimmen, sind nur für die "Klarschrift" falsch entschlüsselt

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Aber andere Überlegung... warum baust du nicht den alten Chip in das neue KI ein und stellst es auf FIS um?

Brauchst Du nicht WFS, km-Stand und Schlüssel und so neu anlernen (hatte gelesen, dass man das dann müsste)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich habe gelesen, dass zum km-Stand und WFS Daten auch andere Daten auf dem EEPROM sein soll. So zum Beispiel eine Kennlinienkorrektur für die Zeigerinstrumente.

 

Blöd ist nur, dass alles zu den Dumps sehr schlecht dokumentiert ist , man findet zig Halbwahrheiten, aber wenig Verlässliches.

(wer hätte es gedacht...:cool::kratz:)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Deshalb meine Überlegung, die alten Daten auf das neue KI zu übertragen (entweder Chip umbauen oder altes (originales File Deines A2) flashen).

Dann müsstest Du nur noch über VCDS oä einstellen, dass es jetzt auch noch ein FIS und nicht nur MFA gibt. Hast Du denn alle benötigten Sensoren? Ansonsten könnten natürlich Fehler in der FIS-Anzeige die Folge sein...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Bitte keine eeproms c&p übertragen, wenn man nicht weiss, wofür die Daten stehen. Wenn dein altes Ki ohne FIS war, wird das Ergebnis ganz sicher ein nicht funktionierendes KI mit FIS sein.

@malesc: Wenn der dump OK ist, sollte es für der Xex editor kein Problem sein, die Daten richtig darzustellen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Muss jeder für sich beantworten. Für mich hat es keinen Sinn gemacht, deswegen gibt es überhaupt das miniFIS.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo Zusammen,

möchte hier noch kurz eine Info abgeben wie sich das Thema entwickelt hat um den Thread abzuschließen.

 

Den Dump im EEPROM des Kombiinstruments habe ich noch mit verschieden Programmern (PICKIT2 & Arduino) ausgelesen und versucht zu interpretieren. Nach dem das minder erfolgreich war, habe ich das Kombiinstrument zu V*G*a*h geschickt und mir Login geben lassen sowie den KM Stand auf 0 setzen lassen.

 

Da ich das Auto nicht (auch nicht zeitweise) funktionsunfähig machen wollte, habe ich das im Auto verbaute Kombiinstrument nicht mitgeschickt (auch wenn hier auch kein Login Code vorhanden war).

So war am Ende doch ein kurzer Besuch beim :) nötig um das anlernen der WFS durchzuführen.

 

Zusammenfassung der Kosten.

ca. 60€ Login + 0km Stand

ca. 35€ WFS und Schlüssel anlernen beim :) (ging 5 min)

ca. 100€ Kombi mit FIS

ca. 110€ für neuen GRA Lenkstockschalter(wurde in dem Zuge auch eingebaut) + gebrauchter FIS Lenkstockschalter + fertige Kabelbäume für GRA und FIS

 

Jetzt funktioniert alles.

 

Eine Merkwürdige Sache habe ich dann aber doch noch...

Und zwar zeigt das Kombiinstrument über VCDS zwei Fahrgestellnummern an (von meinem Fahrzeug + Spenderfahrzeug des FIS Kombis), hat jemand eine Erklärung oder Abhilfe? (Siehe Bild im Anhang)

 

Hier in dem Video bei Minute 1:31 ist das kurz auch so:

 

Gibt aber keine negativen Auswirkungen.

 

Grüße und ein frohes Fest,

TDI-Düser

zwei_FIN.png.596c5a84f134ecfe2f94f74325dc0cd4.png

bearbeitet von TDI-Düser
Fehler

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Eine Merkwürdige Sache habe ich dann aber doch noch...

 

Und zwar zeigt das Kombiinstrument über VCDS zwei Fahrgestellnummern an (von meinem Fahrzeug + Spenderfahrzeug des FIS Kombis), hat jemand eine Erklärung oder Abhilfe? (Siehe Bild im Anhang)

 

Daran kann man erkennen, dass mal ein Austausch des KI vorgenommen wurde. Es ist also nicht mehr original.

 

Das gleiche hast du auch, wenn das Motorsteuergerät getauscht wird. Dann werden im Motorsteuergerät zwei Nummern angezeigt.

 

Ob man das wegbekommt, weiß ich nicht.

bearbeitet von janihani

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo A2-Fan's

 

ich kämpfe - und freue mich auf euere Unterstützung.

 

Auch ich habe mir ein KI mit FIS gekauft, und den Code dazubekommen.

 

Nachdem ich auch VCDS zur Verfügung habe, und heute versucht habe das 'neue' KI anzulernen, hat mir das System mitgeteilt: Block 2 - Transponder gesperrt (1). Und nun komme ich derzeit nicht weiter.

Freue mich über jeden Tipp!

 

Vielen Dank im Vorraus!

:)

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 49 Minuten schrieb 1.4571:

Auch ich habe mir ein KI mit FIS gekauft, und den Code dazubekommen.

 

Nachdem ich auch VCDS zur Verfügung habe, und heute versucht habe das 'neue' KI anzulernen, hat mir das System mitgeteilt: Block 2 - Transponder gesperrt (1). Und nun komme ich derzeit nicht weiter.

Freue mich über jeden Tipp!

 

 

Wie bist du beim Anlernen vorgegangen? Fehlerspeichereinträge vorhanden?

Bezüglich Transponder gesperrt: Schau mal in Messwertblock 24 des KIs.

 

Anleitung zum Anlernen des KI findet sich hier: RossTech - Wiki: Swapping Instrument Cluster

  • Daumen hoch. 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo, und schon mal vorab - Danke.

Fehlerspeicher war vorher leer.

Hatte dann im Kanal 23 Block 2 die Anzeige 1 - Transponder gesperrt.

 

teste gleich noch deine Anleitung. 

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

'All relevant coding and adaptation values have been transferred from the OLD (ORIGINAL) cluster to the REPLACEMENT (NEW or USED) cluster.'

 

Wie kann ich die relevanten Codierungen und Einstellungen vom alten in das neue KI überspielen?

bearbeitet von 1.4571

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Das heisst schlicht, dass man das neue KI über die Anpassungs- und Codierkanälen genauso codieren soll, wie es das alte war.

  • Daumen hoch. 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Kanal 24, alle vier Blöcke auf '0'

 

mich irritiert, dass bei 23/2 die 1 bedeutet, dass der Transponder gesperrt ist.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Solange das KI noch nicht angelernt wurde, halte ich das für normal.

Das neue(gebrauchte) KI kennt die alten Schlüssel noch nicht.

 

  • Daumen hoch. 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

OK,

Bei der o.g. Verfahrensanweisung bin ich darauf gestoßen, dass ich auch vom alten KI den Login benötige.

Den muss ich noch organisieren ...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

O.K. habe ich soweit geschafft. Aber jetzt ?(

 

Habe nach

"Anleitung zum Anlernen des KI findet sich hier: RossTech - Wiki: Swapping Instrument Cluster"

 

das neue KI drinnen. Hat auch die neue KI-Nummer bereits abgespeichert.

wollte dann nach " Proceed with Key Matching now. " die Schlüssel anlernen,

aber da wurde er wieder bockig, d.h. vor dem Schlüsselanlernen muss ich wieder den Login des aktellen KI eingeben, und dann hat er mich nicht mehr weitermachen lassen:

 

VCDS: Zündung ausschalten und etwas warten.

Hab ich über nach warten lassen, aber heute die gleiche Meldung :(

und jetzt?

Kann sein dass ich 24h  warten muss, oder wie, oder ???

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Am 18.2.2017 um 12:22 schrieb 1.4571:

Habe nach

"Anleitung zum Anlernen des KI findet sich hier: RossTech - Wiki: Swapping Instrument Cluster"

 

das neue KI drinnen. Hat auch die neue KI-Nummer bereits abgespeichert.

wollte dann nach " Proceed with Key Matching now. " die Schlüssel anlernen,

aber da wurde er wieder bockig, d.h. vor dem Schlüsselanlernen muss ich wieder den Login des aktellen KI eingeben, und dann hat er mich nicht mehr weitermachen lassen:

 

VCDS: Zündung ausschalten und etwas warten.

Hab ich über nach warten lassen, aber heute die gleiche Meldung :(

und jetzt?

Kann sein dass ich 24h  warten muss, oder wie, oder ???

 

Die VIN/IMMO-ID von Fahrzeug wird nach dem Herstellen der Diagnoseverbindung angezeigt (evtl. sind es auch 2, inkl. der VIN/IMMO-ID vom Spendefahrzeug)?

Was steht in Messwertblock 23/24?

  • Daumen hoch. 2

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 12 Stunden schrieb Phoenix A2:

Die VIN/IMMO-ID von Fahrzeug wird nach dem Herstellen der Diagnoseverbindung angezeigt (evtl. sind es auch 2, inkl. der VIN/IMMO-ID vom Spendefahrzeug)?

Was steht in Messwertblock 23/24?

 

Messwertblock 23:   1 1 0 0

Messwertblock 24:   0 0 0 0

 

@ Phoenix A2: Vielen Danke!

Wär ich nicht drauf gekommen, und versteh den Zusammenhang nicht, evtl. kann mir das jemand erklären:

KI A  mit Code abcd ausgebaut

KI B  mit Code bcde eingebaut

KI B mit Code abcd und bcde angelernt

Wegfahrsperre aktiviert mit Code abcd (vom KI A, das gar nicht mehr in dem Auto ist) !!!

 

Nun zwei neue Problem:

km-Stand - Steht bei dem Wechsel-KI also KI B derzeit auf 000010 km. Möchte ich anpasssen (da unter 100 sollte das gehen)

- Login - mit Code abcd wird akzeptiert

- Anpassung, Kanal 9 und geb dann bei 'Neuer Wert' den km-Stand ein

Anliesend wird das Feld angezeigt: Kilometerstand einstellen ... Login erferderlich; obwohl ich  gerade eben den Login eingegeben habe???

 

das andere Problem

Adresse 19 - findet er nicht? und ich sollte doch noch das CAN-Gateway codieren ....

bearbeitet von 1.4571

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 1 Stunde schrieb 1.4571:

Wär ich nicht drauf gekommen, und versteh den Zusammenhang nicht, evtl. kann mir das jemand erklären:

KI A  mit Code abcd ausgebaut

KI B  mit Code bcde eingebaut

KI B mit Code abcd und bcde angelernt

Wegfahrsperre aktiviert mit Code abcd (vom KI A, das gar nicht mehr in dem Auto ist) !!!

 

Das ist so richtig. Beim Anlernen übernimmt das KI die Daten vom Auto (diese bekommt es vom Motorsteuergerät mitgeteilt, dafür wird der Login  vom alten KI benötigt). Danach sind KI und Mstg wieder synchron was VIN/IMMO-ID angeht.

 

vor 1 Stunde schrieb 1.4571:

Nun zwei neue Problem:

km-Stand - Steht bei dem Wechsel-KI also KI B derzeit auf 000010 km. Möchte ich anpasssen (da unter 100 sollte das gehen)

- Login - mit Code abcd wird akzeptiert

- Anpassung, Kanal 9 und geb dann bei 'Neuer Wert' den km-Stand ein

Anliesend wird das Feld angezeigt: Kilometerstand einstellen ... Login erferderlich; obwohl ich  gerade eben den Login eingegeben habe???

 

Ich gehe mal davon aus dass das kein neues KI ist welches du gekauft hast.? D.h. der Kilometerstand wurde auf 10 zurückgesetzt.

Evtl. wurden vom Verkäufer noch weitere Einstellungen dabei zurückgesetzt. Prüfe mal die Codierung und alle Anpassungkanäle: VCDS hat eine Funktion um alle Anpassungskanäle auszulesen und in eine Textdatei zu schreiben, das hilft beim Vergleichen.

Wir hatten hier schon den Fall, dass ein KI vor Verkauf "zurückgesetzt" wurde und das KI nach dem Anlernen nicht richtig funktionierte weil Anpassungskanäle falsche Werte hatten.

 

vor 1 Stunde schrieb 1.4571:

das andere Problem

Adresse 19 - findet er nicht? und ich sollte doch noch das CAN-Gateway codieren ....

 

Im A2 gibt es kein Stg auf Adresse 19, d.h. kein CAN-Gateway was zu codieren ist. Woher kommt diese Info?

  • Daumen hoch. 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 3 Stunden schrieb Phoenix A2:

Ich gehe mal davon aus dass das kein neues KI ist welches du gekauft hast.? D.h. der Kilometerstand wurde auf 10 zurückgesetzt.

Evtl. wurden vom Verkäufer noch weitere Einstellungen dabei zurückgesetzt. Prüfe mal die Codierung und alle Anpassungkanäle: VCDS hat eine Funktion um alle Anpassungskanäle auszulesen und in eine Textdatei zu schreiben, das hilft beim Vergleichen.

Wir hatten hier schon den Fall, dass ein KI vor Verkauf "zurückgesetzt" wurde und das KI nach dem Anlernen nicht richtig funktionierte weil Anpassungskanäle falsche Werte hatten.

 

vor 4 Stunden schrieb 1.4571:

das andere Problem

Adresse 19 - findet er nicht? und ich sollte doch noch das CAN-Gateway codieren ....

 

Im A2 gibt es kein Stg auf Adresse 19, d.h. kein CAN-Gateway was zu codieren ist. Woher kommt diese Info?

 

Hallo, bin wieder zurück - A2 läuft wieder :)))

 

- KI gebraucht, war richtig.

- viele Einstellungen waren nicht zutreffend bzw. blödsinn

- Adresse 19 - hatte meherer Hinweise (die alle ähnlich waren) nebeneinander, und das war in einer drinnengestanden (war evtl. vom A4)

Vielen Dank, so kann ich morgen wieder zur Arbeit fahren :)

 

Zwei -eigentlich Kleinigkeiten- geben mir noch zu denken:

- mein A2 ist nach 2003, das KI aus 2001. Habe irgendwo etwas gelesen, dass dazwischen eine Änderung des Widerstandes beim Kraftstoffgeber vorgenommen wurde, brauch ich da noch eine spezielle Anpassung/Einstellung oder brauch ich mittelfristig einen anderen Kraftstoffgeber?

 

- Seit dem ersten anstecken des 'neuen' KI motzt dies wegen angeblich defekter Bremsleuchte. Sind aber alle i.O. Anpassungsarbeit oder auch hier ein anderer Schalter?

 

  • Daumen hoch. 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Oh, ein danke für mich! :) , hab doch gar nichts gemacht - ausser Feedback.

 

 Vielen Dank nochmal an Phoenix A2:HURRA:    (Die Knöpfe oben hatte ich schon gedrückt).
 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 4 Minuten schrieb 1.4571:

Oh, ein danke für mich! :) , hab doch gar nichts gemacht - ausser Feedback.

 

Genau, für das Feedback!

Passiert nämlich auch immer wieder mal das man nach einem Tip nichts mehr hört.

Ist ja auch für andere/zukünftige Leser des Threads interessant.

 

  • Daumen hoch. 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Manchmal dauert es etwas, aber ohne Feedback

ist nicht meine Art. :)

 

Hast du noch 'mal Tipp für meine Problemchen?

bearbeitet von 1.4571

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 54 Minuten schrieb 1.4571:

Zwei -eigentlich Kleinigkeiten- geben mir noch zu denken:

- mein A2 ist nach 2003, das KI aus 2001. Habe irgendwo etwas gelesen, dass dazwischen eine Änderung des Widerstandes beim Kraftstoffgeber vorgenommen wurde, brauch ich da noch eine spezielle Anpassung/Einstellung oder brauch ich mittelfristig einen anderen Kraftstoffgeber?

 

Schau mal in diese Liste nach den Teilennummern vom deinem alten und neuen KI: Wiki - Kombiinstrument

Da steht auch der zugehörige Geber für den Kraftstofftank. Wenn da ein Unterschied besteht funktioniert die Tankanzeige entweder etwas ungenau oder ist komplett invertiert (Tank voll = Tanknadel zeigt leer, und ungekehrt).

 

vor 54 Minuten schrieb 1.4571:

- Seit dem ersten anstecken des 'neuen' KI motzt dies wegen angeblich defekter Bremsleuchte. Sind aber alle i.O. Anpassungsarbeit oder auch hier ein anderer Schalter?

Lanpenausfallkontrolle wird von einem eigenen Relais gemacht und der Status mit 2 digitalen Leitungen zum KI gemeldet. Diese Schnittstelle sollte über alle Baujahre einheitlich sein.

Schonmal versucht die entsprechende Eingänge am KI testweise auf Masse zu legen: am grauen Stecker des KIs Pin 14 und 16. Warnmeldung sollte dann aus sein.

Ansonsten wäre noch der Bremslichtschalter zu prüfen, ob dieser noch zuverlässig schaltet.

 

  • Daumen hoch. 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Kraftstoffanzeige - schein zu passen,

aber auch das versteh ich nicht (hab das KI scheinbar aus einem sehr dunklen Kanal bezogen)

- Gehäuse hat eine andere Ident als elektronisch beim Fehlerspeicher hinterlegt, beide Nummern sollten nach dem LInk Kombiinstrument kein FIS haben - aber bei mir ist eins drinnen ... :o

 

-  Bremsichtkontrolle - kümmere ich mich ein andermal drum ...

 

- Drehzahl - ist zu wenig, ich hab im Leerlauf 600, hab vorher die Anpassung und die Codierungen noch einmal durchgesehen, aber irgendetwas muss ich noch übersehen haben ?(

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Anscheinend stammt dein neues KI aus einem Benziner und du hast einen Diesel. Dann hätte dein Problem was mit unterschiedlichen Drehzahlskalierungen bei Benziner (bis 5000+ 1/min) bzw. Diesel (bis 4000 1/min) was zu tun.

 

Falls das wirklich der Fall sein sollte, müsste man die Skalierung im Dump anpassen.

  • Daumen hoch. 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor einer Stunde schrieb 1.4571:

Kraftstoffanzeige - schein zu passen,

aber auch das versteh ich nicht (hab das KI scheinbar aus einem sehr dunklen Kanal bezogen)

- Gehäuse hat eine andere Ident als elektronisch beim Fehlerspeicher hinterlegt, beide Nummern sollten nach dem LInk Kombiinstrument kein FIS haben - aber bei mir ist eins drinnen ... :o

 

Welche Teilenummer hat dein KI denn elektronisch laut Diagnose?

  • Daumen hoch. 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 23 Stunden schrieb Bala_de_plata:

Anscheinend stammt dein neues KI aus einem Benziner und du hast einen Diesel. ......Skalierung im Dump anpassen.

 

1. richtig, ich habe die Drehzahlmesserscheibe selber gewechselt, dachte aber, wenn der richtige Motor eingestellt ist, würde das passen

2. Dump - sagt mir bisher noch gar nichts

 

3. Teilenummer lt Fehlerspeicherprotokoll: 8Z0 920 901 C

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

1. Das Problem kommt mir bekannt vor, ich schau mal nach;-)

2. Sozusagen die Firmware, die im KI steckt. Denk ans Dump von dieser Firmware als eine ISO-Datei beim Digitalisieren einer CD.

3. 1.6FSI, EU, 42 l, guckst du hier.

bearbeitet von Bala_de_plata
  • Daumen hoch. 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

'schau mal nach'

freue mich evtl. findest eine gute Info für mich

 

Dump, also quasi so eine Mischung zwischen Bootmenü und Betriebssystem?

und da gibt es hier einige Kollegen, die -wenn  man ihnen das KI zuschickt- das Dump auslesen/updaten/modifizieren können ?

 

Link war oben schon mal von Phoenix A2, aber ich bin einfach verwundert, weil nach dem Link mit meiner Teilenummer ich kein FIS hätte ?(

 

Also wurde meinem KI vermutlich duch das Dump eine neue Ersatzteilnummer zugeordnet?

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Am 19.2.2017 um 16:59 schrieb Phoenix A2:

 

 

 

Lanpenausfallkontrolle wird von einem eigenen Relais gemacht und der Status mit 2 digitalen Leitungen zum KI gemeldet. Diese Schnittstelle sollte über alle Baujahre einheitlich sein.

D.h. Relais ersetzen? Wo ist dieses? Welche Teilenummer hat es?

 

Am 19.2.2017 um 16:59 schrieb Phoenix A2:

Schonmal versucht die entsprechende Eingänge am KI testweise auf Masse zu legen: am grauen Stecker des KIs Pin 14 und 16. Warnmeldung sollte dann aus sein.

D. h. Belegung belassen, und diese beiden Eingänge zusätzlich mit Masse versehen?

 

Am 19.2.2017 um 16:59 schrieb Phoenix A2:

Ansonsten wäre noch der Bremslichtschalter zu prüfen, ob dieser noch zuverlässig schaltet.

Leuchtet bei Betätigung immer. Durchmessen? Sind erforderliche Werte bekannt?

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 11 Stunden schrieb 1.4571:

D.h. Relais ersetzen? Wo ist dieses? Welche Teilenummer hat es?

Relais (bei A2 mit FIS ab Werk) befindet sich oberhalb des Sicherungsträgers hinter der Verkleidung unterhalb des Lenkrades.

Teilenummer ist 4B0 919 471 A, meist ist auch noch die Zahl "393" aufgedruckt zu finden.

 

vor 11 Stunden schrieb 1.4571:

D. h. Belegung belassen, und diese beiden Eingänge zusätzlich mit Masse versehen?

 

Das würde ich als erstes testen, d.h. die beiden oben beschriebenen Eingänge auf Masse legen (sonstige Belegung unverändert lassen).

Dann sollten die Warnmeldungen zur Beleuchtung aus sein, wenn das KI funktioniert.

  • Daumen hoch. 1

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Mal was anderes am Rande...

Ich würde mir gern im KI von 1,2er die Tankkennlinie vom 42L Tank aufspielen. Ab Werk lässt sich das KI nur auf den 20L und 34L Tank codieren.

Kann mir jemand sagen in welchem Adressbereich ich die Daten dazu finde?

Ich könnte auch kurzfristig an die Daten von einem A2 mit 42L Tank kommen.

Nur kann ich mir den Dump von diesem nicht 1 zu 1 auf mein KI spielen, da das KI vom 1,2er eine andere Tachoskalierung hat und noch die Daten vom Getriebesteuergerät anzeigt.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Die Tankkennlinie liegt im Addressbereich 0x015E - 0x017D und sieht bei einem 8z0920931B (FIS, Diesel, ATL, 42l) so aus:

931B.thumb.png.3d979a47b9d0efe3ffcf3964239ecc55.png

 

Bei einem 8z0920980R (FIS, Benzin, Meilentacho, 42l) ist die Kennlinie um Nuancen verschoben, was m.E. nicht ins Gewicht fällt:

980R.thumb.png.855dabffdbffa42008daf1f91ff1c94a.png

 

Beide KIs benutzen den gleichen Tankgeber.

 

Geschwindigkeitsskalierung liegt im Speicherbereich 0x0C4 - 0x0E3.

Drehzahlmesserskalierung liegt im Speicherbereich 0x10A - 0x119.

 

  • Daumen hoch. 6

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden